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General Safety Summary 

Review the following safety precautions carefully before operate the device to avoid any 

personal injuries or damages to the device and any products connected to it. To avoid 

potential hazards use the device as specified by this user’s guide only. 

 

 To Avoid Fire or Personal Injury 

 Use Proper Power Cord. Use only the power cord specified for this product and 

certified for the country of use. 

 Connect and Disconnect Properly. Do not connect or disconnect probes or test 

leads while they are connected to a voltage source. 

 Connect and Disconnect Properly. Connect the probe output to the measurement 

device before connecting the probe to the circuit under test. Disconnect the probe 

input and the probe reference lead from the circuit under test before disconnecting 

the probe from the measurement device. 

 Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings 

and markings on the product. Consult the product manual for further ratings 

information before making connections to the product. 

 Use Proper Probe. To avoid shock hazard, use a properly rated probe for your 

measurement. 

 Avoid Circuit or Wire Exposure. Do not touch exposed connections and 

components when power is on. 

 Do Not Operate With Suspected Failures. If suspected damage occurs with the 

device, have it inspected by qualified service personnel before further operations. 

 Provide Proper Ventilation. Refer to the installation instructions for proper 

ventilation of the device. 

 Do not operate in Wet/Damp Conditions. 

 Do not operate in an Explosive Atmosphere. 

 Keep Product Surfaces Clean and Dry. 

 

 



                                                             PSO-120                                                             

User’s Manual                                                               2 
 

 

Chapter 1 Getting Start 

The oscilloscope is small, lightweight, no external power required, portable oscilloscopes! 

The oscilloscopes is ideal for production test, research and design and all of the 

applications involving analog circuits test and troubleshooting, as well as education and 

training. 

  

In addition to the list of general features on the next page, this chapter describes how to 

do the following tasks: 

 

 System Requirements 

 Install software 

 Install driver 

 General Features 

 General Check 

 Functional Check 

 self calibration 

 Accessories 
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1.1 System Requirement 

To run the oscilloscope software, the needs of computer configuration are as follows: 

  

Minimum System Requirements 

Operating System 

Windows XP/Vista/7/8/8.1/10   32bits and 64bits 

  

Processor 

Upwards of 1.00G processor 

  

Memory 

256M byte 

  

Disk Space 

500M disk free space 

  

Screen resolution 

800 x 600 

  

Recommended Configuration 

Windows XP SP2 System 

2.4G Processor 

512M Byte Memory 

80G Disk Space 

1024 x 768 or 1280 x 1024 resolution 

DPI Setting: Normal Size (96DPI) 
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1.2 Install Software 

Caution: You must install the software before using the oscilloscope. 

 

1. While in Windows, insert the installation CD into the CD-ROM drive. 

2. The installation should start up automatically. Otherwise in Windows Explorer, switch 

to the CD-ROM drive and run Setup.exe. 

3. The software Installation is started. Click 'Next' to continue.  
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4. Choose a destination directory. Click 'Next' to continue.  

 

 
 
5. Check the setup information. Click Next to start copying of files. 

 

 
 
 
 



                                                             PSO-120                                                             

User’s Manual                                                               6 
 

 

6. This Status dialog is displayed during copying of files.  

 

7. Updating Your System Configuration. 

 

8. The installation is complete. 
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1.3 Install Driver 

1. Connect the A-Type Plug of USB cable to your PC’S USB port. 

      

2. New hardware is found. 

 

3. New hardware search wizard starts. 

    

5.  New hardware search wizard starts to search the driver. 
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6. New hardware wizard installs “DRIVER”. 
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7.  The wizard has finished installing for “DRIVER”. 

   

8. Your new hardware is installed and ready to use. 
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1.4 General Features 

 Maximum real-time sample rate: 96MSa/s 

 Memory depth: 1Mbytle/channel 

 Built-in Fast Fourier Transform function(FFT); 

 20 Automatic measurements; 

 Automatic cursor tracking measurements; 

 Waveform storage; 

 User selectable fast offset calibration; 

 Adjustable waveform intensity, more effective waveform view; 

 User interface in several user-selectable languages; 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



                                                             PSO-120                                                             

User’s Manual                                                               11 
 

 

1.5 General Check 

Please check the instrument as following steps after receiving an oscilloscope: 

 

 Check the shipping container for damage: 

Keep the damaged shipping container or cushioning material until the contents of the 

shipment have been checked for completeness and the instrument has been checked 

mechanically and electrically. 

 Check the accessories: 

Accessories supplied with the instrument are listed in "Accessories" in this guide. If 

the contents are incomplete or damaged，please notify the franchiser. 

 Check the instrument: 

In case there is any mechanical damage or defect, or the instrument does not operate 

properly or fails performance tests, please notify the franchiser. 

 

1.6 Function Check 

Perform this functional check to verify that your oscilloscope is operating correctly. 

 Connect the oscilloscope 

You should connect the A-Type Plug of USB cable to your PC USB port and connect 

the probe with the signal source. 

         

 Input a signal to a channel of the oscilloscope 

 

Please input signal in the following steps: 

connect the probe with the signal source and ensure good grounding clip.  
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1. Attach the tip of probe and ground nip to the Connector of Probe. A square wave 

will be displayed within a several seconds. (Approximately 1 kHz, 2V, peak- to- 

peak). 

 

1.7 Self Calibration 

The self calibration routine lets you optimize the oscilloscope signal path for maximum 

measurement accuracy. You can run the routine at any time but you should always run the 

routine if the ambient temperature changes by 5℃ or more. For accurate calibration, 

power on the oscilloscope and wait twenty minutes to ensure it is warmed up. To 

compensate the signal path, disconnect any probes or cables from the input connectors. 

Then, access the “Menu -> Utility -> Calibration” option and follow the directions on the 

screen. The self calibration routine takes about several minutes. 

 

 

1.8 Accessories 

All the accessories listed below are standard accessories for the oscilloscope: 

 A PC software CD of the oscilloscope 
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Chapter 2 Operating Basics  

 
 The User’s Interface 
 
 The Menu System 
 
 The Vertical System 
 
 The Horizontal System 
 
 The Trigger System 
 

 Input Connector 
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2.1 The User’s Interface 

Click the software icon on the desk after you finished the software setting and equipment 

connecting. Then a user interface will be showed as follows: 

 

In addition to displaying waveforms, the display area is filled with many details about the 

waveform and the oscilloscope control settings. 

1. The Main Menu 

All settings can be found in the main menu. 

2. The Toolbar 

3. Control Panel 

4. DVM 

5. The Horizontal Panel 

The user can change Time/Div, format in the panel. 

6. The Vertical Panel 

The user can turn on/off the CH1. Also the user can change the CH1 volt/div. 

7. The Trigger Panel 

In this panel, the user can change the trigger mode, sweep,slope. 

8. Displays the system time. 

9. Displays Sample Rate 

10. Displays the main time base setting. 

11. Displays the CH1 information 

Readouts show the coupling of the channels. 
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Readouts show the vertical scale factors of the channels. 

12. Output Window 

13. The markers show the reference points of the displayed waveforms. If there is 

no marker, the channel is not displayed. 

14. Measure Window. 

15. Trigger state 

16. "Running": The program found the hardware and the hardware works normally. 

"Searching Device": Not find the device and the program is searching the 

device. 

2.2 Button description 

The buttons with PSO-120 pen storage oscilloscope as follows: 

 

 

1、Voltage（V ） 

“+”button 
Single click：Voltage increase 

Keep clicking：continuous increase with Voltage 

“-” button 
Single click：Voltage decrease 

Keep clicking：continuous decrease with Voltage 

R/S button 
Single click：RUN or STOP 

Keep clicking：AUTO SET 

2、OFFSET (V↕) 

“+” button 

Single click：Waveform moves down 

Keep clicking：Waveform continuous downward 

movement 

“-” button 

Single click：Waveform move upward 

Keep clicking ： Waveform continuous upward 

movement 

R/S button 
Single click：RUN or STOP 

Keep clicking：AUTO SET 

3、POSITION (T↔) 

“+” button 
Single click：left shift 

Keep clicking：left shift  continuous 

“-” button 
Single click：right shift 

Keep clicking：right shift  continuous 
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R/S button 
Single click：RUN or STOP 

Keep clicking：AUTO SET 

4、TIME (T ) 

“+” button 
Single click：Time  increase 

Keep clicking：continuous increase with Time 

“-” button 
Single click：Time decrease 

Keep clicking：continuous decrease with Time 

R/S button 
Single click：RUN or STOP 

Keep clicking：AUTO SET 

5、combination button   “+” & “R/S” 
Single click：LED lamp switch 

 

6、- “-” - 

 

 

2.3 The Menu System 

The Main Menu 

   

1. File: Load or Save data, setup 

 

2. View: Change the user interface 
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3. Horizontal: Set the horizontal system 

  

4. Vertical: Set the vertical system 

 

5. Trigger: Set the trigger system 

 

6. Display: The waveform display setup 

 

7. Cursor: Cursor measure setup 

 

8. Utility: Utility setting  
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9. Help: Turn on help file 

 

2.4 The Vertical System 

Click “Vertical” in main menu 

The following figure shows the vertical system menu. It shows the vertical parameters 

setting. 

 

1. CH1: Leads to the setting of the CH1 parameters 

Use the left mouse button to dragging the channel icon to set the vertical position offset 

precisely. 

 

2.5 The Horizontal System 

Click “Horizontal” in main menu 

The following figure shows the Horizontal System window. It shows the horizontal 

parameters settings. 

 

1. Time/DIV: leads the setting of the time base parameters 

2. Format: leads the setting of the horizontal format parameters 
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The time base ranges of the oscilloscope is listed as follows. The horizontal scan speed is 

from 4ns/div to 1hour/div. 

In the “Format” menu of the “Horizontal” menu, select the display mode to Y-T. 

 

 

2.6 The Trigger System 

Click “Trigger” in main menu. 

 

 

Mode: Sets the trigger mode to Edge trigger 

Sweep: Selects the trigger sweep mode to AUTO, NORMAL or SINGLE 

Source: Selects the trigger source to CH1. 

Slope: Selects the edge trigger slope to Positive or Negative slope 

The user can drag the trigger icon to adjust the trigger level and the trigger level will be 

displayed on the top right corner. 

 

2.7 Input Connectors 

Input Connectors: 
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CH 1: Input connectors for waveform display. 

GND.: a ground terminal 

USB PORT: Connect the A-Type Plug of USB cable to your pc. 
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Chapter 3 Understanding Function 

 

 Set Oscilloscope 

 

 Set Vertical System 

 

 Set Horizontal System 

 

 Set Trigger System 

 

 Measure Signal 

 

 Utility Function 

 

 The Display System 

 

 Save/Load 

 

 Print 
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3.1 Set Oscilloscope 

Save Setup 

The oscilloscope software saves the current setup before you close the oscilloscope 

software. The oscilloscope recalls this setup the next time you run the software. You can 

use the “Save Setup” menu to permanently save up to several different setups. 

  

Load Setup 

The oscilloscope can recall the last setup before the oscilloscope software was running, 

any saved setups, or the factory setup. You can use the “Load Setup” menu to 

permanently recall a setup.  

Factory Setup 

The oscilloscope software is set up for normal operation when it is shipped from the 

factory. This is the factory setup. To recall this setup, push the “Factory Setup” menu. 

3.2 Set Vertical Systems 

Click “Vertical” in main menu 

 

 

The Vertical Menu function: 

 

 Turn ON/Off:  Turn on/off the channel  

 Volt/DIV:  Select the channel voltage/div 

 Invert:          Turns the displayed waveform 180 degrees 

 

 Change Volt/DIV 

 

You can click “Volt/Div” in “CH1” Menu to select the voltage 

 

You can also change “CH1” voltage in sidebar 
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You can left click and drag the mouse on the green knob or the yellow knob to change the 

voltage.  

 

 Invert 

 

The invert function turns the displayed waveform 180 degrees, with respect to the ground 

level. When the oscilloscope is triggered on the inverted signal, the trigger is also inverted. 

Click “Invert” in vertical. 

Turn off invert 

 

Turn on invert 

 

The following picture shows the waveform before inversion: 

 

The following picture shows the waveform of inversion: 
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3.2.1 Set FFT 

Fast Fourier Transform Function 

To use the FFT mode, you need to click   in Toolbar to open the FFT setup window.  

The FFT setup window: 

 

 

You can select the Source channel, Window algorithm, FFT number, and FFT Zoom 

factor. It displays only one FFT spectrum at a time. 

Source:  
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 Selects the channel used as the FFT source 

Window:  

 Selects the FFT window type 

Scale:    

 Selects the vertical scale units 

Vert Scale：  

 Selects the vertical scale 

HORI Scale:  

 Selects the FFT zoom factor 

Sets horizontal scale, If the information is more than the quantity displayed to the display 

window, more information is displayed by using scroll bar. 

 

You can click the “ON/OFF” button to start FFT math, also you can click this button to stop 

FFT math. 

 

3.2.2 Set Reference 

Click “ ” in Toolbar to set REF. 

The Reference Channel Function: 

 Turn On/Off:  Turn on/off the reference channel. 

 Volt/DIV:  Channel the resolution of the reference channel. 

 Time/DIV:     leading the setting of the time base parameters. 

 

You can change the vertical scale of a waveform. The waveform display will contract or 

expand relative to the reference level. 
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The Reference Waveform Display Window: 

 

Note: If you turn on the “Reference” channel, the load file window will appear. 

 

3.3 Set Horizontal System 

The following figure shows the Horizontal System window. It shows the horizontal 

parameters settings. 

     

1. Time/DIV: leads the setting of the time base parameters 

 

 

2. Format: leads the setting of the horizontal format parameters 

The time base ranges of the oscilloscope is listed as follows. The horizontal scan speed is 
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from 4ns/div to 1hour/div. 

In the “Format” menu of the “Horizontal” menu, select the display mode to Y-T. 

 

 

3.4 Set Trigger System 

Click “Trigger” in main menu. 

 

The trigger determines when the oscilloscope starts to acquire data and display a 

waveform. When a trigger is set up properly, it can convert unstable displays or blank 

screens into meaningful waveforms. 

If the oscilloscope wants to acquire a waveform, it collects enough data so that it can draw 

the waveform to the left of the trigger point. The oscilloscope continues to acquire data 

while waiting for the trigger condition to occur. The oscilloscope continues to acquire 

enough data so that it can draw the waveform to the right of the trigger point after it 

detects a trigger. 

The Edge trigger determines whether the oscilloscope finds the trigger point on the rising 

or the falling edge of a signal. Select Edge trigger mode to trigger on Rising edge or 

Falling edge. 

Mode: Select the trigger mode. 

 

The oscilloscope only provides edge trigger mode. 

Sweep: Set the sweep mode to Auto, Normal or Single. 

 

 Auto: Acquire waveform even no trigger occurred 

 Normal: Acquire waveform when trigger occurred. 
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 Single: Acquire waveform when trigger occurred then stop 

Slope: Set the slope to Rising (+) or Falling (-). 

 

 Rising: Trigger on rising edge 

Falling: Trigger on falling edge 

 

3.5 Measure Signal 

3.5.1 Cursor 

Click “Cursor” in main menu. 

 

This method allows you to take measurements by moving the cursors 

1. Source 

 

The user can set the source to CH1.  

2. Type 

 

There are four types of cursors: Cross, Vertical and Horizontal. 

 

1) Cross 

The Cross cursors appear as cross lines on the display and measure the vertical and 

horizontal parameters. 

The Cross cursor display window: 
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2) Vertical 

The Vertical cursors appear as vertical lines on the display and measure the vertical 

parameters. 

The Vertical cursor display window: 

 

3) Horizontal 

The Horizontal cursors appear as horizontal lines on the display and measure the 

horizontal parameters. 

The Horizontal cursor display window: 
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3.5.2 Measure  

 

Click “Measure Window” in “View” menu. 

The oscilloscope provides 20 parametric auto measurements (12 voltage and 8 time 

measurements). 

 

1. Vertical 

 

Maximum: Voltage of the absolute maximum level, Measured over the entire waveform 

Minimum: Voltage of the absolute minimum level, Measured over the entire waveform 

Peak To Peak: Peak-to-peak = Max – Min, Measured over the entire waveform 

Top: Voltage of the statistical maximum level, Measured over the entire waveform 

Base: Voltage of the statistical minimum level, Measured over the entire waveform 
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Middle: Voltage of the 50% level from base to top 

RMS: The Root Mean Square voltage over the entire waveform 

Amplitude: Amp = Base – Top, Measured over the entire waveform 

Mean: The arithmetic mean over the entire waveform 

Cycle Mean: The arithmetic mean over the first cycle in the waveform 

Preshoot: Positive Overshoot = (Max - Top)/Amp x 100 %, Measured over the entire 

waveform 

Overshoot: Negative Overshoot = (Base - Min)/Amp x 100 %, Measured over the entire 

waveform 

 

2. Horizontal 

 

Period: Time to take for the first signal cycle to complete in the waveform 

Frequency: Reciprocal of the period of the first cycle in the waveform 

Rise Time: Time taken from lower threshold to upper threshold 

Fall Time: Time taken from upper threshold to lower threshold 

+Duty Cycle: Positive Duty Cycle = (Positive Pulse Width)/Period x 100%, Measured of 

the first cycle in waveform 

-Duty Cycle: Negative Duty Cycle = (Negative Pulse Width)/Period x 100%, Measured of 

the first cycle in waveform 

+Pulse Width: Measured of the first positive pulse in the waveform. The time between the 

50% amplitude points 

-Pulse Width: Measured of the first negative pulse in the waveform. The time between the 

50% amplitude points 

 

3. Clear Measure 

Clear all measure items on display screen. 

The Measure Display Window: 
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Note: The results of the automatic measurements will be displayed on the bottom of the 

screen. Maximum 8 results could be displayed at the same time. When there is no room, 

the next new measurement result will make the previous results moving left, out of screen. 

 

3.6 The Utility Function 

Click the “Menu -> Utility” to get into the “Utility” menu. 

 

The “Utility” Functions: 

 Default Setup 
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 Interpolation 

 Language 

 

3.6.1 Default Setup 

Click “Default Setup” in “Utility” menu to load default setups 

 

When you click the Default Setup in Utility menu, the oscilloscope displays the CH1  

waveforms and removes all other waveforms.  

The oscilloscope set up for normal operation when it is shipped from the factory and can 

be recalled at anytime by user. 

The Factory Setup function does not reset the following settings: 

 Language option 

 Date and time 

 

3.6.2 Language 

Click “Language” in “Utility” menu.  

 

There are four languages in “Language” menu. The default language is English. 

 

3.6.3 Interpolation 

Click “Utility->Interpolation”. 
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At the time base 40ns/div or faster, user can use the 3 different interpolation mode to get 

waveforms of different smoothness. 

The Step Interpolation: 

 

 

 

The Linear Interpolation: 
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The Sin(x)/x Interpolation: 

 

Note: The default interpolation mode is Sin(x)/x. 
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3.7 The Display System 

Click “Display” in main menu. 

The following figure shows the display system menu. Displays parameters setting. 

 

 Type 

 Grid 

 Intensity 

3.7.1 Type 

Click “Type” in “Display” menu. 

 
 

 

If the Vectors type mode is selected, the waveform will be displayed as following figure. 

 

If the Dots type mode is selected, the waveform will be displayed as following figure. 
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3.7.2 Grid 

Click “Display” in main menu. 

 

The grid shows: 
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Without the grid show: 

 
 

3.7.3 Intensity 
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Click “Display->Intensity” in main menu  

The following figure shows the intensity dialog. It shows the display parameters setting. 

 

You can change the grid and waveform color intensity in this dialog. 
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3.8 Save/Load Menu 

Click “File” in main menu to save waveform, setups and screen 

 

1. Save Data 

Save waveform data  

2. Save Setups 

Save the current oscilloscope setups to file 

 

Load Menu 

Click “File” in main menu to recall saved waveform, setup 

 

 

1. Load Data 

Load the waveform 

2. Load Setup 

Load the instrument that had saved 
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3.9 Print 

Click “Print” in File. 

 
1.  Click “Print” in “File” menu to set the printer to print the current waveform. 

2.   Click the “Print Preview” in “File” menu to get into the Preview window. 

In “Print Preview” window, use the  button to change the size of the waveform 

graph. Click the “Close” button to turn this window off and click the “Print” button to print 

the report. 
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Chapter 4 Application Example 

 

 Simple Measurement 

 

 Capturing a Single-Shot Signal 

 

 Taking Cursor Measurement 
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4.1 Simple Measurement 

To acquire and display a signal, please do the steps as follows: 

Connect signal to CH1 by using probe 

The oscilloscope set the vertical, horizontal, and triggers controls at the best status 

automatically. Also, you can adjust the controls to meet your measurement to optimize the 

waveform display. 

 

1. To measure the frequency and “Vpp”, you can do these steps as follows: 

2. Click the  button, the frequency of the signal display on the bottom of 

the waveform interface. 

3. Click the  button, the “Vpp” of the signal will also display on the 

bottom of the waveform interface. 

4. To clear the measurement on the waveform interface, click the  button. 
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The results of measure display in Information output. 

   

 

4.2 Capturing a Single-Shot Signal 

To capture a single event, it needs to gather some pre-test knowledge of the signal in 

order to set up the trigger level and slope correctly. For example, if the event is derived 

from 3.3V COMS logic, a trigger level of 1.2 or higher Volts should work on a rising edge.  

  

Do these steps as follows:  

  

1. Set up the trigger in the Trigger Menu, or in the Trigger Setting window.  

1) Adjust the Trigger Mode to Edge.  

2) Set the Trigger Sweep to Single.  

3) Set the Trigger Slope to “+” which means you select the rising edge. 

4) Adjust the Volts/Div and the time base in a proper range for the signal.  

5) Drag the trigger level sign on the waveform display screen to proper position. It’s 

usually higher a little above the normal level. 
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6) When the trigger conditions are met, data appears on the display representing 

the data points that the oscilloscope obtained with one acquisition.  

 

4.3 Taking Cursor Measurements 

Use cursors to make time and amplitude measurements on a waveform quickly.  

  

Measure the Peak Frequency or Time of the First Sine Waveform 

  

Do these steps:  

1. Click “Cursor->Source”, select CH1. 

2. Click “Cursor->Type”, select Vertical. 

3. Push left mouse button, and the vertical lines appear. 

4. Drag the mouse button to the point you want to measure. 

5. Release the left mouse button, the frequency difference and time difference will be 

shown at the status bar. 

 

 
Measure the Amplitude of the First Waveform Peak of the Waveform 

  

Do these steps: 

  

1. Click “Cursor->Source”, select CH1. 

2. Click “Cursor->Type”, select Horizontal. 

3. Push left mouse button, and the Horizontal lines appear. 

4. Drag the mouse button to the point you want to measure. 
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5. Release the left mouse button, the voltage difference will be shown at the status bar. 

        

 
 

Note: Click “Cursor->Type”, select “Cross”, you can measure time and amplitude at one 
time. 
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Appendix A: Specification 

Specifications Table: 

Input  

Max. sample rate Real-time sampling:96MS/s 

Channels  1 Channels  

Bandwidth  20MHz (-3dB) 

Vertical resolution  8 bits/channel  

Gain range  20mV～20V/div 

Range  8 divisions  

Offset level  +/-4 divisions  

Coupling  DC/AC/GND 

Offset increments  0.02 div  

Impedance  1M ohm  

DC accuracy  +/-3%  

Max. Input 35V 

Input protection 60Vpk(Without external attenuation DC + peak AC < 10kHz) 

Display mode  Y-T 

Timebase  

Timebase range  

1ns/div～5000s/div(1ns,2ns,5ns,10ns,20ns,50ns,100ns,200ns, 

500ns,1us,2us,5us,10us,20us,50us,100us,200us,500us, 

1ms,2ms,5ms,10ms,20ms,50ms,100ms,200ms,500ms,1s,2s, 

5s,10s,20s,50s,100s,200s,500s,1000s,2000s,5000s/div 1,2,5 

sequence) 

Range  10 divisions  

Buffer Size  MAX.1M samples 

Trigger  

Type  Edge trigger: Rising edge, Falling edge 

Mode  Auto, Normal and Single  

Autoset  Yes(100Hz-20MHz)  

Range  8 divisions  

Trigger level  +/-4 divisions  

Settabillity  0.02 div increments  

Math  

Measurements  

Vp-p, Vmax, Vmin, Vmean, Vrms, Vamp, Vtop, Vbase, 

Vmid,positive overshoot, negative overshoot, cycle mean, cycle 

RMS, period, frequency, positive pulse width, negative pulse 

width, rise time (10%~90%), fall time (10%~90%), positive duty 

cycle, negative duty cycle  

Math  FFT 

FFT  Rectangular, Hanning, Hamming, Blackman Window  

Physical 



                                                             PSO-120                                                             

User’s Manual                                                               49 
 

 

Interface  Universal Serial Bus(USB 2.0) 

Power  
No external power source required.  

Bus-powered from USB  

Dimensions  230x40x 20(mm) 
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Appendix B: General Maintenance 

General Care 

Do not store or leave the oscilloscope where the device will be exposed to direct sunlight 

for long periods of time. 

Caution 

To avoid damages to the device or probes, do not expose them to sprays, liquids or 

solvents. 

To avoid damages to the surface of the device or probes not use any abrasive or chemical 

cleaning agents. 

Cleaning 

Inspect the device and probes as often as operating conditions require. Make sure the 

device disconnect form all power sources. 

To clean the exterior surface, perform the following steps: 

1.  Remove loose dust on the outside of the oscilloscope and probes with a lint-free cloth. 

Use care to avoid scratching the clear glass display filter. 

2.  Use a soft cloth dampened with water to clean the device.  
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